B!

"過去の自分が泣いて喜ぶようなことをアウトプットしよう" という旨のことがどこかの記事に書いてあったのがすごく印象に残ってる。そうありたい ( ˘ω˘)

Ruby on Rails 4 でのエラー(Specified 'sqlite3' for database adapter, but the gem is not loaded.)

Ruby on Rails 4 を始めたところ、いきなりつまづいたのでメモ

window (x64)でやってます。

環境を構築して、プロジェクト作って、サーバを起動したら、

Specified 'sqlite3' for database adapter, but the gem is not loaded. Add `gem 'sqlite3'` to your Gemfile.

というエラーメッセージが・・・

Gemfile に sqlite3 は書いてあるのに動かない

 

Gemfile.lock 内の

sqlite3 (1.3.8-x86-mingw32) を

sqlite3 (1.3.8-x64-mingw32)

とすると上手くいきました。